Администраторам сайтов на WordPress, использующих плагин WP Live Chat Support, следует немедленно обновить его до версии 8.0.33, так как в плагине присутствует критическая уязвимость, позволяющая обойти процесс аутентификации. Злоумышленники могут использовать этот баг, не имея корректных учетных данных.

На сегодняшний день проблемный плагин установили около 50 тыс. сайтов. Задача WP Live Chat Support — предоставлять бесплатный чат, позволяющий общаться с посетителями, обеспечивая техническую поддержку.

Исследователи команды Alert Logic обнаружили, что 8.0.32 и более ранние версии плагина позволяют пользователям, не прошедшим процесс аутентификации, получить доступ к конечным точкам REST API. Все благодаря критической бреши, которая отслеживается под идентификатором CVE-2019-12498.

В результате успешной эксплуатации этого бага атакующий может извлечь логи чатов, а также модифицировать сессии. Другими словами, злоумышленник сможет получить не только переписки с клиентами, но и изменить каждое текстовое сообщение в чате.

Для тех администраторов, которые не могут обновить версию плагина, эксперты Alert Logic описали способ, позволяющий временно защитить ваши сайты от атак с использованием этой уязвимости.

Читайте также