С выходом плановых сентябрьских обновлений безопасности компания Adobe исправила две критические уязвимости, позволяющие выполнить произвольный код на системе. Проблемы затрагивают десктопную версию Adobe Flash Player 32.0.0.238 и более ранние для Windows, macOS, и Linux, а также Adobe Flash Player для  Chrome на Windows, macOS, Linux и Chrome OS. Уязвимостям также подвержена версия Adobe Flash Player 32.0.0.207 и более ранние для  Edge и Internet Explorer 11 на Windows 10 и 8.1.

CVE-2019-8070 представляет собой уязвимость использования памяти после высвобождения, а CVE-2019-8069 — это уязвимость вида «same origin method execution», позволяющая атакующему выполнять от имени пользователя непредусмотренные действия. Проэксплуатировав обе уязвимости, злоумышленник может выполнить произвольный код в контексте текущего пользователя.

Сентябрьские обновления безопасности также исправляют уязвимость в установщике Windows-приложения Adobe Application Manager. CVE-2019-8076 связана с небезопасной загрузкой библиотек и позволяет осуществить взлом DLL.

Помимо прочего, компания Adobe исправила уязвимости записи/чтения данных за пределами выделенной области памяти, переполнения кучи, внедрения команд и type confusion (несоответствие используемых типов данных).

Читайте также