Специалисты команды Google Project Zero обнародовали информацию (а также PoC-код) об уязвимости в операционной системе Android, которая уже активно используется злоумышленниками в реальных атаках. Примечательно, что данная уязвимость была исправлена в версиях Android 3.18, 4.14, 4.4 и 4.9 в декабре 2017 года, однако вновь появилась в более поздних релизах ОС.

Проблема, получившая идентификатор CVE-2019-2215, содержится в коде ядра Android и может быть использована для полной компрометации устройства. По словам исследователей, уязвимость затрагивает гаджеты на базе версий Android 8.х и выше:

Pixel 2 на базе Android 9 и Android 10 preview

Huawei P20;

Xiaomi Redmi 5A;

Xiaomi Redmi Note 5;

Xiaomi A1;

Oppo A3;

Moto Z3;

Oreo LG;

Samsung S7, S8, S9.

По мнению специалистов команды Google Threat Analysis Group (TAG), используемый в атаках эксплоит был разработан израильской компанией NSO Group, имеющей весьма неоднозначную репутацию. Ранее компанию неоднократно обвиняли поставке эксплоитов авторитарным правительствам, преследующим правозащитников и журналистов. В сентябре нынешнего года NSO Group пообещала следовать принципам принятой Всеобщей декларации прав человека и принять меры, препятствующие использованию технологий компании со злым умыслом.

Хорошая новость заключается в том, что CVE-2019-2215 не может использоваться для удаленного выполнения кода, ее эксплутация требует ряда условий. В частности, злоумышленнику вначале потребуется установить на целевое устройство вредоносное приложение, а для эксплуатации через web-браузер потребуются дополнительные эксплоиты.

Устроившая голый протест актриса стала депутатом

Читайте также